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Introduction
It used to be that, when using a normal fancy camera, one had to focus the image onto
the film by turning the lens. Fancy digital cameras sometimes let you do this, but most
often, focussing is done by the camera electronics: the electronics shifts the position of
the lenses which create the image closer or farther away from where the image is finally
detected. If the focus is "off", i.e. the distance between the lenses and the detector is too
large or too small, then the image is blurry. When the focal distance is correct, the image
is "sharp". Large astronomical telescopes are heavy pieces of equipment even when they
are very precise, so it's not too surprising that one also has to focus them. As with the
fancy digital camera, it is possible to automate this process, but one learns a lot about
telescope optics by doing it by hand.

Imagine some very fancy telescope optics which produce images so fine, that all stars
appear to be infinitely tiny points of light (it turns out that this is physically impossible, but
we'll ignore that for now). The lenses or mirrors take parallel rays of light coming from a
particular direction and bend them so that those rays come together after a distance
equal to the focal length of the telescope, where the image is produced. If we move the
camera either closer or farther away from the focus, then the image produced is no longer
a point but something with a shape between a point and the shape of the optics; for a
circular lens or mirror, an out-of-focus image looks like a uniformly illuminated circle. If we
had to block out some of the light of the primary mirror to support other mirrors that
bounce the light back and forth before coming to a focus, the patch of light which was
blocked out is also missing in the out-of-focus image. Reflecting telescopes usually have
secondary mirrors placed immediately in front of the primary mirrors, blocking out a bit of
light in the center of the primary, so out-of-focus images from reflectors tend to look like
flat donuts.
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A diagram showing how the width of an image depends upon the distance from the place where the telescope has its focus.  
Far from the focus,  the unfocussed image grows linearly.

To make the best possible images, one has to move either the camera or the optics back
and forth until one finds the position where the objects are "sharpest" - for stars, this
means they should not look like donuts but as very narrow spots of light, the narrower the
better. To find the best focus, one takes a series of images with different focal distances
and measures how the images "blur" as a function of that distance. The exposures have
to be long enough that the atmospheric conditions during the time the camera is exposed
were similar, typically longer than 5-10 seconds. The exposure times have to be varied
carefully since focussed images concentrate lots of light into tiny images and de-focussed
images contained large and faint donuts.

This chapter shows you how to focus a telescope (or camera) by hand using a series of
images taken of stars (or other point-like sources like bacteria). General information about
using telescopes is avaiable in the chapter  Using an Imaging Telescope . Other hints
about remote observing can be found in the chapter  A Remote Observing Recipe Book 
.

Some telescope systems maintain the telescope focus automatically. Others support
creating a single image with multiple images of stars taken with different focus settings. If
the telescope is not remote, you can often focus by reading out the camera very quickly
and modifying the focus by hand until the live image is sharpest. However, for remote
telescopes, most of the time you will need to take a series of images for each focus
setting and determine the focus yourself - this is certainly the didactically best way of
learning how to use a telescope. Each telescope has it's own setting and reasonble range:
the MONET/North Telescope's focus is usually around 51mm, depending upon the
temperature and (to a lesser degree) the filter.

Note that you may have to focus for each filter individually, depending upon the telescope
and filter. Also, if the temperature of the telescope changes during the night, the best
focus value may change: monitor the telescope/outer temperatue and consider re-
focussing if things change a log (or your images start to get worse).

Obtaining the Focus Images
You will need about 7-10 images taken at a range of focus values (for MONET/North
about +/- 1.0mm) in order to be able to cover a value close to the optimal one and to
have enough range of image sizes to measure the best value. Using the hyperbola-fitting
plugin in the ImageJ Astronomy package, you can easily use even badly focussed
images where the stars have turned into donuts - indeed, these images actually contain
the most focussing information: see the section on telescope focussing in  Using an
Imaging Telescope .
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Don't expose for less than a few seconds - the typical seeing pattern needs a few
seconds to build up and have a shape worth measuring - nor for so long, that the
telescope tracking, wind-buffetting, or other problems dominate.

The task of later reducing all kinds of images within ImageJ is much simpler if the images
are organized into groups that can be read in as a complete stack using File > Import
> Image Sequence..., e.g. in a special focus directory for the images taken explicitly
for focussing purposes.

To obtain the required focus images:

1. find a good star to focus on (e.g. a standard star you can use for determining fluxes
in W/m2; see the  list below );

2. determine the range of focus values you want to cover (e.g. 50.00 to 52.00 mm);

3. determine how many focus images you want to take and the corresponding focus
values (e.g. 9 images at 50.00, 50.25, 50.50, 50.75, 51.00, 51.25, 51.50, 51.75,
52.00);

4. for each focus value,

change the telescope focus;

take an exposure;

download the image, preferably into a special focus sub-directory;

You will have to be careful when choosing your exposure times: the amount of total light
from the star shouldn't change by much, so a badly focused image has stars whose light
has been spread out considerably - such images may require longer exposures.

Measuring the Focus Images
In order to find the focus, we must determine the width of the stellar images. For didactic
purposes, this can be done "by hand" using the ImageJ line tool:

1. Select the line tool from the ImageJ toolbar;

2. Draw a line from one side of the stellar image to the other, while not releasing the
left mouse button;
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3. As long as the left mouse button is kept down, you will see the length of the line
segment in the lower left info space of the ImageJ toolbar;

4. When you are happy with the total length, release the mouse button and measure
the final length using Analyze > Measure (or the keyboard shortcut); the length of
your line will appear in a Results table.

5. Continue this process for all images in the focus stack, noting the focus value for
each slice within the stack (e.g. from the FITS headers viewable via Image > Show
Info ...).

The problem with this method is that it is very inexact, particularly for well-focussed
images, since it is very difficult to define a quantitative "width" of a narrow image: the
apparent width differs greatly depending upon how the images are displayed.

A much simpler and objective method is to use the Aperture Photometry Tool
normally used to measure the brightness of focussed stellar images. With an aperture
measurement, you can also get the centroid and mean moment width of the image.

1. Find out if the telescope focus was stored in the image header: select Image >
Show Image Info ... and search the header for an entry giving the telescope
focus (e.g. "FOCUS", "TEL-FOCU", "TELFOCUS" or something similar). If you find
one, you can let ImageJ note the focus values instead of having to write them down
by hand.

2. Use your cursor or a line segment to estimate the maximum size of the most poorly
focussed image in your stack. It may help to zoom up to a star image using the
Magnifying Glass in the toolbar (or simply press the "+" key).

3. Double-click on the Aperture Photometry Tool icon in the ImageJ toolbar (if you
don't see one, you may have to get the Astronomy Tools by clicking on the >>
symbol at the right edge of the toolbar) or select the Plugins > Astronomy >
Set Aperture menu item.



4. Enter the radius of your largest stellar image (1/2 of the length of your line
segment) as the Radius of object aperture.

5. Enter a slightly larger radius for Inner radius of background annulus and an
even larger radius for Outer radius of background annulus. This background
annulus is necessary for the moment-width calculation.

6. Make sure that
List centroid position
... mean moment width
Display object aperture in overlay
... sky annulus in overlay
Clear overlay before use

are all selected as shown above (earlier versions of the Astronomy plugins may
have different text or may lack some of these entries).

7. If you found the telescope focus in the FITS header, select
8. (List)... the decimal values for the FITS keywords

and enter the name of the keyword in the text box (e.g. TEL-FOCU).

9. Close the Aperture Photometry Parameters dialog with "OK".

10. Measure a prominent (but not saturated) image of a single star (without close
neighbors) within each slice by simply clicking on the star. After every click, a
measurement will be recorded in a Measurement Table, including the name of the
slice, the position of the star, the width, and - if available - the telescope focus value
from the FITS header.

Fitting the Focus Curve
The plugins > Astronomy > Find Telescope Focus plugin finds the best focus from
the focus and width values by fitting a hyperbola to the data. The input data can be
entered using many methods.

If you had to write down your focus and width values (e.g. using the ImageJ line tool to



measure widths and looking at your observing log for the focus values), then you simply
enter the values into the default text area:

If the width values have been obtained using the Aperture Photometry Tool, then
they are available in a Measurement Table. The focus values can then been obtained by

extracting the focus values from the image file names (e.g. in the file name
"focus_51.20.fits", the focus value can be read using the pattern
"focus_*.fits", where the asterix "*" represents the focus value);

typing in a simple list of focus values ("Unordered sequence");

defining an "Ordered sequence" of focus values defined by a beginning value, a
regular increment, and a maximum value (assuming that the width measurements
were made in EXACTLY this order!); or the simplest method,

reading the focus values previously extracted from the FITS headers as described
in the previous section.



Once the source of the focus values is set, pressing "OK" results in fitting the data with a
hyperbola.

The exact details are output into the log window, including the best focus value (the
center of the hyperbola) and its error. This value should then be used for the telescope
and should definitely be noted in your observing log for later use.

Note the two asymptotes of the focus curve: these are exactly the lines corresponding to
the rays visible in the  telescope sketch  at the beginning of this chapter: for a very small
focussed image, any shift away from that perfect focus results in a linear increase in the
size of the de-focussed image.

Handy Links
Standard Stars for fluxes and focussing:

 http://www.noao.edu/wiyn/queue/images/tableB.html 

An Introduction to Astronomical  Image Processing with  ImageJ (C) Copyright Hessman & Modrow 2008. 
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