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Things that go bump in the night* 

One normally thinks of using astronomical images to study the 
appearance or color of an object: a single grayscale image just shows the 
angular structure of objects on the sky (position, size, and shape) at a 
particular wavelength; two or more grayscale images taken at different 
wavelengths can be put together to show the "color" of the image, i.e. 
how the angular structure and/or amount of light changes with 
wavelength.  

Stars don't have any particularly interesting shape in images (just the 
smearing effects of the atmosphere and the telescope) and producing 
color images of stars has only limited use. One might think individual 
stars are therefore relatively boring objects to observe, but in fact the 
opposite can be true: some of the most exciting objects to observe are 
those that change not in position or wavelength but time.  

There are many astronomical objects that change their brightness with 
time:  

stars that change their sizes and temperatures when ringing like 
bells, e.g. the Cepheid stars used to measure astronomical 
distances (see the chapter on  Measuring Distances to Galaxies );  
objects that explode catastrophically, e.g. supernovae and gamma-
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ray bursts;  
objects that change their brightness due to heating, e.g. so-called 
cataclysmic variables;  
objects that change their brightness due to rotation, e.g. because of 
the appearance and disappearance of starspots;  
eclipsing binary stars orbiting around each other can sometimes 
cover each other up when viewed from the Earth;  
eclipses or magnifications of two unrelated objects that just 
happend to be on the same line-of-sight when viewed from the 
Earth, e.g. gravitational microlenses (see the chapter on  Hands-
On General Relativity ).  

The time it takes for these events to happen can be as short as a few 
seconds (e.g. gamma-ray bursts) to months and years (e.g. supernovae). 
Many of these events take place on timescales as short as a single night 
or over a few days, making them ideal objects to study - not many things 
happen in the universe over times short enough to be interesting to 
humans! 

A record of the changes in the brightness of astronomical objects with 
time is called a "lightcurve", usually a simple graph with time on the X-
axis and some measure of the brightness on the Y-axis. If the data are 
taken over a long time, there are usually gaps in the data due to cloudy 
nights or simple lack of access to a telescope, so it may be difficult to 
know for sure just what is happening. If the phenomena happen on very 
short timescales of hours or less, it is possible to make a complete record 
of the variations.  

This chapter explains how to measure and display the light variations 
from a simple stellar object. The general methods apply to any set of 
images taken over time from the same object, but the main focus is the 
special case of a uniform set of images taken with the same camera and 
telescope on the same night, where the major problem is simply dealing 
with a large number of very similar images:  

1. Prepare a stack containing the images to be measured;  
2. Find the star to be measured and one or more reference stars;  
3. Perform aperture photometry on the stars;  
4. Produce a plot of the relative brightness of the object as a function 

of time.  

*"From ghoulies and ghosties and long-legged beasties and things that go bump in the 
night, good Lord deliver us!" (supposedly Scottish prayer usually attributed to Walter de 
la Mare).  
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Astronomical Time 
For most purposes, the time associated with an astronomical observation 
is about the same as civil time - the pictures were taken, e.g., in Texas on 
the 21st of June, 2009, at 9:00 PM, Central Standard Time (expressed in 
a standard international format as 2009-06-21T21:00:00-7), or in 
Göttingen on the 24th of December, 2009, at 11:59:59 PM, Middle-
European-Time (2009-12-24T23:59:59+1).  

There are many tools on the internet which can help you to convert back 
and forth between civil time and Julian Date. Thus, the previous two 
dates can be expressed as  

 
Note that midnight in Greenwich is always when the fractional 
Julian Date is 0.5, not 0.0. When using this system, it's easy to compute 
the amount of time between the two events: 2455190.45832 minus 
2455004.66667 is 185.79165 days. 

If you are studying the changes in a supernova over 
the course of months, this is all you may need to 
know, but it is also very difficult to compute the exact 
amount of time that has passed between the two 
observations. For this reason, astronomers often use 
not the normal civil date and time but the JULIAN 
DATE (or Julian Day, usually abbreviated as "J.D."), 
the number of days which has passed since 12 
o'clock noon on January the 1st, 4713 B.C.E. in 
Greenwich. This makes the time independent of the 
location, making it easier to compare observations 
taken at different places, and is independent of things 
like leap-years. 

Concepts  
 

JULIAN DATE 

Date, Time, & Place ISO Date-Time Julian Date 
(J.D.)

21st of June, 2009 
9:00 PM, Central Standard 
Time 
Texas

2009-06-
21T21:00:00-7 2455004.66667

24th of December, 2009 
11:59:59 PM, Middle-
European-Time 
Göttingen

2009-12-
24T23:59:59+1 2455190.45832

If more exact time is needed, then 
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For many astronomical purposes, simple J.D. is simply, handy, and good 
enough.  

If you are measuring FITS images, the image headers should contain 
enough information to compute the Julian Date for each observation:  

1. Take a look at the FITS header using Image > Show Info... and 
see if you can see the typical header entries DATE-OBS (the date and 
hopefully date-time of the observation), TIME-OBS (the time of the 
observation if not already contained in DATE-OBS), EXPTIME (the 
exposure time for very accurate times), and maybe even JD; 

2. Using Plugins > Astronomy > Set Aperture (or double-click on the 
Aperture Photometry Tool icon), select List ... Julian Date of 
image (if available); 

3. If the Julian Date is given explicitly in the FITS header, you can 
select List ... the decimal values for the FITS keywords 
called ... and enter the keyword containing the Julian Date (e.g. 
"JD" or "JUL-DAY"); 

one has to correct for the fact that 
the Earth was at two different places 
in it's orbit in June and in December: 
it takens light 149,598,000 km / 
299,792 km/s = 499 seconds (8.3 
minutes) to traverse the distance 
between the Sun and the Earth, 
resulting in a correction to 
HELIOCENTRIC JULIAN DATE 
(HJD, the Julian Date for an 
observer at the center of the Sun). 
Even more exact corrections can be 
made for having different observers 
at different locations on the Earth or 
for putting the standard observe not 
at the Sun but the center-of-mass of 
the Solar System ("Barycentric 
Julian Date"). Modern astronomers 
no longer think that the astronomical 
day stars at noon and get tired from 
writing so many decimal places, so a 
MODIFIED JULIAN DATE (MJD) 
where 2400000.5 has been 
subtracted, is commonly used. 

Concepts  
 

HELIOCENTRIC JULIAN DATE 
MODIFIED JULIAN DATE 
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Pre-processing the images 
If the set of images taken of an object over a period of time is very 
inhomogenous, then each image must be calibrated and measured 
individually. If the data are reasonably homogenous - as is the case when 
the observations were made with the same instrument under the same 
conditions or even in one observing session - then the images can be 
calibrated and measured en masse using ImageJ's stack capabilities:  

1. Produce and save any calibration images needed (see the 
chapter  Calibrating Raw Images  or the  Data-Reduction Recipe 
Book ); Load the calibration images into ImageJ (but you may want 
to iconify them to get them out of the way); 

2. Load the images into a stack using the File > Import > Image 
sequence... command (the number of images you can load into a 
stack depends upon the amount of memory available on your 
computer and allocated by ImageJ; see Edit > Options > Memory 
& Threads...); 

3. Calibrate all the images in the stack using Plugins > CCD > 
Process Images; 

4. Align all the images in the stack if the images wander somewhat 
(e.g. poor tracking by the telescope over the long times observed) 
using the Plugins > Stacks > Align Stack plugin (see the chapter 
on  Making Movies )); 

5. You may want to crop the stack to contain only the parts of the 
images of interest (mainly the object to be measured and the 
reference star(s) used to measure the relative brightness variations) 
using a rectangular section selection and the Image > Crop 
command, particularly if you aligned the images in the stack.  

The end-result is a stack of images showing the object to be measured 
and one or more reference stars.  

 
 

 
Defining the objects to measure 
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If your object is very faint or occationally disappears alltogether, you will 
need to know the position of the star exactly so that you can force 
ImageJ to measure it at the right position. The simplest way to do this is 
to  

1. Align the images in the stack so that all stars are always at the 
same position (Plugins > Stacks > Align Stack as described 
before); 

2. Construct an average image using Image > Stacks > Z-
Project ...; 

3. Measure the exact position of all your stars in the average image 
using the Aperture Photometry tool; make sure you select the 
option within Plugins > Set Aperture (or double-click on the 
aperture photometry tool icon) to print out the centroid positions and 
to re-center the aperture to obtain a very accurate position 
(unselect the "Use the clicked position, do not reposition" option);  

4. The results will be shown in a results table - note the X- and Y-
positions of the stars (to several decimal places) - these are the 
positions you should use!  

 
 

 
Multi-Aperture Photometry 

If your object is very bright, you'll have no problem 
measuring the variable in each image, but if there 
are many objects in the field, you may have to 
employ a FINDER CHART, an image of the field 
where the object has been identified, or calibrate 
the image astrometrically. You will need one or 
more reference images, preferably several that are 
brighter than the variable object (but not so bright 
that the image is saturated). 

Concepts  
 

FINDER CHART 

The light from the objects is measured 
using the simple technique of 
APERTURE PHOTOMETRY: a circle 
with a particular radius R* is defined 
encompassing the light of the object 
plus any background light (due to the 
Moon, etc.); an annulus defined by an 
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While you can measure all of the objects and standard stars by hand, the 
simplest technique is to measure all of the stars in all of the images in the 
stack at once using the Plugins > Astronomy > MultiAperture plugin:  

1. Display the first image of the stack; 

2. Enter the number of stars to be measured (one main target object 
and one or more reference stars) as Number of apertures per 
image; 

3. Select the option All measurements from one image on the same 
line.; 

4. Select the option Compute ratio of 1st aperture to others 
(only if on same line).; 

5. Press "OK" and then click on each image to be measured on each 
image, in the correct order - the main target object first!  

If your object is faint and so hard to measure in individual images, it's 
better to force ImageJ to use a specific position for the apertures:  

1. Find the positions of the stars using the average image from the 
whole stack, as mentioned in the previous section; 

2. Using Plugins > Astronomy > Set Aperture (or double-click on the 
Aperture Photometry Tool icon), select Use the clicked position, 
do not reposition (only works if the images stay at the same 
positions or if the stack has been aligned); 

3. Select the stars using Plugins > Astronomy > MultiAperture as 
above, put click only after the cursor is at the right positions 
(displayed in the ImageJ toolbar window).  

If the plugin is unable to get throught the entire stack (e.g. a too large 

inner radius Rin and an outer radius 
Rout centered on the same circle 
defines the background around the 
object and from which the background 
contribution at the position of the object 
can be subtracted. Of course, the radii 
have to be selected carefully: see the 
chapter  Measuring Brightness  for 
more details. 

Concepts  
 

APERTURE PHOTOMETRY 
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shift in the position of your stars, try the following:  

increase the size of your apertures to allow for more motion before 
ImageJ gets lost;  
perform the MultiAperture analysis only on blocks of the stack at a 
time;  
align the stack if you haven't already.  

The result should be a Measurement table containing at least the entries  

image (name of image);  
x (pixel X-position of target object);  
y (pixel Y-position of target object);  
source-sky (total brightness of target object minus the sky 
background);  
ratio1 (ratio of target object brightness to sum of reference star 
brightnesses).  

and perhaps J.D.-2400000 (Julian Date measured relative to 2400000) if 
you selected the option to calculate the Julian Date. 

Advanced users can also have the errors of the measurments calculated 
using the gain and read-out-noise of the camera.  

 
 

 
Plotting the lightcurves 
The tables produced by the MulitAperture plugin can be stored as 
simple text files and read into graphing programs such as Excel 
(Windows, OSX), OpenOffice (all operating systems), and gnuplot 
(mostly Unix-like operating systems such as Linux and OSX). Import the 
data into a spreadsheet and plot the "J.D.-2400000" axis versus the 
"ratio1" axis. If you weren't able to let ImageJ calculate the Julian Date, 
you may have to enter the date and/or time by hand (e.g. by deriving it 
from the file name).  

Starting with the 2009 version of the Göttingen Astronomy plugins, there 
is a Plugins > Input-Output > Read Measurement Table tool which 
enables you to read tables stored as text files back into ImageJ.  

Starting with the 2009 version of the Göttingen Astronomy plugins, there 
is a Plugins > Graphics > Plot Table Columns tool which enables you 
to plot one column of table data against another, just as you are 
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accustomed to doing within a spreadsheet program (though not as well). 
The columns to be plotted and a few other parameters can be input to the 
plugin but the appearance of the standard (and pretty stupidly simple) 
ImageJ plot image can be modified by invoking Edit > Options > Plot 
Profile Options ....  

 
A lightcurve plot made directly from an ImageJ Measurement table.  

 
 

 
Example Data 
Here are some test data showing a very clean eclipse of a compact white 
dwarf star by its binary companion. Load all of this data into a stack, 
convert the stack to 32-bits (floating numbers), align it (best by shifting to 
whole pixels rather than interpolating), and then measure the brightness 
of the eclipsing binary using an aperture which doesn't get re-centered.  

 
 

(C) Copyright Hessman & Modrow 2009. None of this material may be used, copied, or distributed for commercial 

purposes. Version: 2009-02-02  
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